Commit 82f88cab authored by Dan Poltawski's avatar Dan Poltawski
Browse files

MDL-35864 enrol: misc fixups

* Removed get_config_instance_capabilities() which was from
  older reviewed vrsions of the patch
* Added note to upgrade.txt
* Fixed deprecation note
* Bump versions
parent 12bdea2e
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051201; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_category'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 60;
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_cohort'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 60*60; // run cron every hour by default, it is not out-of-sync often
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051201; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_database'; // Full name of the plugin (used for diagnostics)
//TODO: should we add cron sync?
......@@ -25,7 +25,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_flatfile'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 60;
......@@ -24,6 +24,6 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_guest'; // Full name of the plugin (used for diagnostics)
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051201;
$plugin->requires = 2014050800;
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_imsenterprise';
$plugin->cron = 60;
......@@ -25,6 +25,6 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_ldap'; // Full name of the plugin (used for diagnostics)
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_manual'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 600;
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_meta'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 60*60; // run cron every hour by default, it is not out-of-sync often
......@@ -24,6 +24,6 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051201; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_mnet'; // Full name of the plugin (used for diagnostics)
......@@ -25,7 +25,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_paypal'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 60;
......@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
$plugin->version = 2014051200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014050800; // Requires this Moodle version
$plugin->version = 2014072200; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2014072200; // Requires this Moodle version
$plugin->component = 'enrol_self'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 600;
This files describes API changes in /enrol/* - plugins,
information provided here is intended especially for developers.
=== 2.8 ===
* enrol_plugin::instance_deleteable() is deprecated and has been replaced by enrol_plugin::can_delete_instance()
=== 2.6 ===
* Enrolment plugin which supports self enrolment should implement can_self_enrol()
......
......@@ -1541,7 +1541,7 @@ abstract class enrol_plugin {
* Is it possible to delete enrol instance via standard UI?
*
* @deprecated since Moodle 2.8 MDL-35864 - please use can_delete_instance() instead.
* @todo MDL-35864 This will be deleted in Moodle 2.9.
* @todo MDL-46479 This will be deleted in Moodle 3.0.
* @see class_name::can_delete_instance()
* @param object $instance
* @return bool
......@@ -2324,14 +2324,4 @@ abstract class enrol_plugin {
// Implement if you want to restore protected group memberships,
// usually this is not necessary because plugins should be able to recreate the memberships automatically.
}
/**
* Which capabilities are needed to configure the enrol instance via standard UI
*
* @return array Array with capabilities needed to configure the enrol instance
*/
public function get_config_instance_capabilities() {
return array();
}
}
......@@ -29,7 +29,7 @@
defined('MOODLE_INTERNAL') || die();
$version = 2014071700.00; // YYYYMMDD = weekly release date of this DEV branch.
$version = 2014072200.00; // YYYYMMDD = weekly release date of this DEV branch.
// RR = release increments - 00 in DEV branches.
// .XX = incremental changes.
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment