upgrade.txt 2.67 KB
Newer Older
1
2
3
This files describes API changes in /blocks/* - activity modules,
information provided here is intended especially for developers.

4
5
6
7
=== 3.3 ===

* block_manager::get_required_by_theme_block_types() is no longer static.

8
9
10
11
12
13
=== 3.1 ===

* The collapsed class was removed from the navigation block to make it compatible with aria.
* New aria attributes were added on the navigation block [aria-expanded="false"].
* The tree JS handling were moved from YUI to AMD module (Jquery).

14
15
=== 2.9 ===

16
* The obsolete method preferred_width() was removed (it was not doing anything)
17
* Deprecated block_base::config_save as is not called anywhere and should not be used.
18
19
* Added instance_copy() function to the block_base class. This function allows for block
  specific data to be copied when a block is copied.
20

21
22
23
24
25
26
27
28
29
30
31
32
=== 2.8 ===

* The instance_config_print() function was removed. It was deprecated in
  Moodle 2.0, but without debugging notices. Since it was no longer a part
  of the code path, debugging notices would not have been displayed.
* Deprecated functions were removed from the block_base class:
** _print_block()
** _print_shadow()
** _title_html()
** _add_edit_controls()
** config_print()

33
34
35
36
=== 2.6 ===

* Deprecated /admin/block.php was removed, make sure blocks are using settings.php instead.

37
38
39
40
41
42
43
=== 2.4 ===

Created new capability 'blocks/xxx:myaddinstance' that determines whether a user can add
a specific block to their My Home page. This capability was only defined for blocks where
the applicable_formats function does not include "'my' => false" in the returned array,
allowing it be added to the My Home page.

44
45
46
47
48
49
=== 2.3 ===

required changes in code:
* block_xxx_pluginfile() is now given the 7th parameter (hopefully the last one) that
  contains additional options for the file serving. The array should be re-passed
  to send_stored_file().
50

51
52
53
54
55
56
57
58
59
60
=== 2.0 ===

required changes in code:
* use new DML syntax everywhere
* use new DDL syntax in db/upgrade.php
* replace defaults.php by settings.php and db/install.php
* replace STATEMENTS section in db/install.xml by db/install.php
* move post instalation code from install() method into db/install.php
* completely rewrite file handling
* rewrite backup/restore
61
62
* theme changes: move plugin styles into blocks/xxx/styles.css and use new css markers for images,
                 move all images into new blocks/xxx/pix/ directory and use new outputlib api
63
                 old global $THEME is fully replaced by $OUTPUT
Petr Skoda's avatar
Petr Skoda committed
64
* remove '_utf8' from language pack names, use new {$a} syntax in language packs
65
* use 'pluginname' lang pack identifier instead of 'blockname'
66
* move cron and version number into standard version.php
67
* removed support for old config_global.html, use settings.php
68